澳洲幸运5号码统计|澳洲幸运5是哪个国家的
載入中...
在線檢測未來函數
載入中...

通達信短準狠主圖指標公式

來源:Internet,編輯:股旁網,2019-09-25

MA10:=MA(C,10),COLOR009B9B,LINETHICK1;
MA20:=MA(C,20),COLOR009B9B,LINETHICK1;
HX:=MAX(REF(C,1),H);
LX:=MIN(REF(C,1),L);
DRAWBAND(MA10,RGB(231,150,69),MA20,RGB(18,128,144));DRAWKLINE(HX,O,LX,C);
老筆:=0;
G:=MA(C,5);
D:=MA(C,10);
HH:=REF(H,5)=HHV(H,11);
LL:=REF(L,5)=LLV(L,11);
FG01:=BACKSET(HH,6)>BACKSET(HH,5) ;
FD01:=BACKSET(LL,6)>BACKSET(LL,5) ;
FG02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND G>D,FG01,
IF(BARSLAST(FD01)>BARSLAST(FG01),FG01,0));
FD02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND D>G,FD01,
IF(BARSLAST(FG01)>BARSLAST(FD01),FD01,0));
FG0:=FG02 AND H=HHV(H,BARSLAST(FD02));
FD0:=FD02 AND L=LLV(L,BARSLAST(FG02));
GP:=IF(FG0,H,DRAWNULL),CIRCLEDOT,COLORCYAN;
DP:=IF(FD0,L,DRAWNULL),CIRCLEDOT,COLORCYAN;
GQ:=L>REF(H,1) AND DAY!=REF(DAY,1);
DQ:=H<REF(L,1) AND DAY!=REF(DAY,1);
GQL:=REF(L,BARSLAST(GQ));
DQH:=REF(H,BARSLAST(DQ));
FGH:=REF(H,BARSLAST(FG0));
FGL:=REF(L,BARSLAST(FG0));
FGH1:=REF(H,BARSLAST(FG0)+1);
FGL1:=REF(L,BARSLAST(FG0)+1);
FGH2:=REF(H,BARSLAST(FG0)+2);
FGL2:=REF(L,BARSLAST(FG0)+2);
FDH:=REF(H,BARSLAST(FD0));
FDL:=REF(L,BARSLAST(FD0));
FDH1:=REF(H,BARSLAST(FD0)+1);
FDL1:=REF(L,BARSLAST(FD0)+1);
FDH2:=REF(H,BARSLAST(FD0)+2);
FDL2:=REF(L,BARSLAST(FD0)+2);
FGZH:=IF(FGL<=FGL1,FGH2,FGH1);
FGZL:=IF(FGH1<FGL,FGL,IF(FGL<=FGL1,FGL2,FGL1));
FDZH:=IF(FDL1>FDH,FDH,IF(FDH>=FDH1,FDH2,FDH1));
FDZL:=IF(FDH>=FDH1,FDL2,FDL1);
FG1:=FGH>FDZH AND FG0;
FD1:=FDL<FGZL AND FD0;
FG:=FG1 AND FGH>FDH AND FGL>FDL AND FGL1>FDL;
FD:=FD1 AND FDL<FGL AND FDH<FGH AND FDH1<FGH;
BH0:=(H<=REF(H,1) AND L>=REF(L,1)) OR (H>=REF(H,1) AND L<=REF(L,1));
BHG:=COUNT(BH0,BARSLAST(FD0));
BHD:=COUNT(BH0,BARSLAST(FG0));
BGQ:=COUNT(GQ,BARSLAST(FD0));
BDQ:=COUNT(DQ,BARSLAST(FG0));
BK0:=IF(BHG>0,BHG+2+老筆,IF(BHD,BHD+2+老筆,3));
BK:=IF(BGQ,BK0-BGQ,IF(BDQ,BK0-BDQ,BK0));
G1X:=(FG AND BARSLAST(FD)>BK);
D1X:=(FD AND BARSLAST(FG)>BK);
G1:=(FG0 AND REF(H,BARSLAST(FG0))>=REF(H,BARSLAST(G1X)) AND BARSLAST(D1X)>BARSLAST(G1X))
OR (FG1 AND COUNT(GQ,BARSLAST(FD1))>0 AND REF(H,BARSLAST(FG1))>REF(H,BARSLAST(G1X)));
D1:=(FD0 AND REF(L,BARSLAST(FD0))<=REF(L,BARSLAST(D1X)) AND BARSLAST(G1X)>BARSLAST(D1X))
OR (FD1 AND COUNT(DQ,BARSLAST(FG1))>0 AND REF(L,BARSLAST(FD1))<REF(H,BARSLAST(D1X)));
G1H:=IF(BARSLAST(D1)>BARSLAST(G1),REF(H,BARSLAST(G1)),REF(H,BARSLAST(D1))),;
D1L:=IF(BARSLAST(G1)>BARSLAST(D1),REF(L,BARSLAST(D1)),REF(L,BARSLAST(G1)));
G2:=G1 AND H=HHV(G1H,BARSLAST(D1)+1) AND H>REF(H,1) AND BARSLAST(D1)>BARSLAST(G1);
D2:=D1 AND L=LLV(D1L,BARSLAST(G1)+1) AND L<REF(L,1) AND BARSLAST(G1)>BARSLAST(D1);
G3:=G2 OR (FG0 AND REF(H,BARSLAST(FG0))>REF(H,BARSLAST(G2)) AND BARSLAST(D2)>BARSLAST(G2));
D3:=D2 OR (FD0 AND REF(L,BARSLAST(FD0))<REF(L,BARSLAST(D2)) AND BARSLAST(G2)>BARSLAST(D2));
GPB:=IF(G1X,H,DRAWNULL),CIRCLEDOT,COLORYELLOW;
DPB:=IF(D1X,L,DRAWNULL),CIRCLEDOT,COLORYELLOW;
{畫折線}
NN:=G3;
UU:=D3;
L1:DRAWLINE(NN,H,UU, L,0),COLORDAC272,LINETHICK1;
L2:DRAWLINE(UU,L,NN, H,0),COLOR009393,LINETHICK1;
三一:H-(H-L)*0.333,NODRAW;
二一:H-(H-L)*0.5,NODRAW;
三二:H-(H-L)*0.666,NODRAW;
實體三一:O+(C-O)*0.666,NODRAW;
實體腰線:O+(C-O)*0.5,NODRAW;
{多彩K線-主圖公式, 顯示大陽\\大陰\\漲停\\跌停\\假陰\\假陽\\跳空\\大K線中點,適用于通達信 }
DRAWTEXT_FIX(ISLASTBAR,0,0,0,HYBLOCK);{在屏幕左上角顯示所屬行業板塊}
DRAWTEXT_FIX(ISLASTBAR,0.05,0,0,DYBLOCK);{在屏幕左上角顯示所屬地域板塊}
DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,GNBLOCK);{在屏幕左上角顯示所屬概念板塊}
{跳空}
{STICKLINE(REF(L,1)>H,H,REF(L,1),5,0),COLORGRAY;
STICKLINE(REF(H,1)<L,L,REF(H,1),5,0),COLORGRAY;}
C_: CONST(C),COLORLIRED,POINTDOT;{現價線}
MA5:=MA(C,5);
MA5角度: ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416,NODRAW;
DRAWKLINE(H,O,L,C);{重繪K線}
RC1:=REF(C,1);
CS:=IF(C>=1,10000,100000);
C漲停10:=1.10*RC1-49/CS;{考慮到4舍5入}
C漲停5 :=1.05*RC1-49/CS;
C跌停10:=0.90*RC1+51/CS;
C跌停5 :=0.95*RC1+51/CS;
ST:=NAMELIKE('S') OR NAMELIKE('*S');
漲停:= IF(ST, C>=C漲停5, C>=C漲停10);
跌停:= IF(ST, C<=C跌停5, C<=C跌停10);
盤中漲停:=IF(ST, H>=C漲停5, H>=C漲停10);
盤中跌停:=IF(ST, L<=C跌停5, L<=C跌停10);
STICKLINE(盤中漲停,H,MAX(C,O),0,0),COLORMAGENTA;{漲停后回落}
STICKLINE(盤中跌停,L,MIN(C,O),0,0),COLORLICYAN;{跌停后回升}
大陽線:=C>O AND (C>=C漲停5 OR C>(1.05*O-51/CS) ) OR (C>1000 AND C>RC1*1.024);
STICKLINE(大陽線,O,C,1,0),COLOR0000BB;
大陰線:=C<O AND (C<=C跌停5 OR C<(0.95*O+49/CS) ) OR (C>1000 AND C<RC1*0.976);
STICKLINE(大陰線,O,C,1,0),COLORLIGREEN;
STICKLINE(漲停,O,C,1,0),COLORMAGENTA;
STICKLINE(跌停,O,C,1,0),COLORLICYAN;
假陰:=C<O AND C>REF(C,1);
STICKLINE(假陰,O,C,0,0),COLORRED;{假陰柱};
假陽:=C>O AND C<REF(C,1);
STICKLINE(假陽,O,C,0,0),COLORGREEN;{假陽柱};
大盤TJ:=PERIOD=5 AND NAMELIKE('上證指數')
AND (ABS((C-REF(C,1)))/REF(C,1)>=0.025 OR ABS(C-O)>=60);
STICKLINE(大盤TJ,(H+L)/2,(H+L)/2,2,0),COLORYELLOW;{顯示大盤日線的60點大K線中值};
STICKLINE((大陽線 OR 大陰線 OR 漲停 OR 跌停)
AND BETWEEN(C,1,500),L+(H-L)/2,L+(H-L)/2,1,0),COLORYELLOW;{大K線畫中點線};

通達信短準狠主圖指標公式

 

相關文章

澳洲幸运5号码统计 刺激战场国际版 pk10技巧单双稳赚 深海捕鱼达人单机游戏 梦幻西游打125装备赚钱吗 6粒复式二中二多少组 重庆老时时开奖360 开奖结果 澳门银座时时彩平台 黑龙江快乐10分开奖 彩票中心官方app叫什么 cm3d2如何赚钱 炸金花两个人怎么打套 时时宝宝计划免费版 纸黄金和股票哪个赚钱 金兔六肖稳赚中特 重庆正规大小单双计划