澳洲幸运5号码统计|澳洲幸运5是哪个国家的
載入中...
在線檢測未來函數
載入中...

通達信有效突破主圖指標公式

來源:Internet,編輯:股旁網,2019-09-20

Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLOR00C0C0;
ZF:=ABS(100*(H-L)/REF(C,1))>3;
DIF:=EMA(CLOSE,8)-EMA(CLOSE,13);
DEA:=EMA(DIF,6);
MACD:=2*(DIF-DEA);
金叉:=CROSS(DIF,DEA); 死叉:=CROSS(DEA,DIF);
DIF下拐:=REF(DIF,3)<REF(DIF,2)AND REF(DIF,2)<REF(DIF,1)AND REF(DIF,1)>DIF=REF(DIF,1);
MACD下拐:=REF(DIF,3)<REF(DIF,2)AND REF(MACD,2)<REF(MACD,1)AND REF(MACD,1)>MACD=REF(MACD,1);
下拐:=MAX(DIF下拐,MACD下拐);
GD1:=EVERY(DIF>REF(DIF,1),BARSLASTCOUNT(DIF>DEA))AND DIF>DEA;
GD2:=EVERY(MACD>REF(MACD,1),BARSLASTCOUNT(DIF>DEA))AND DIF>DEA;
GD:=MAX(GD1,GD2);
高點1:=REF(MAX(C,O),BARSLAST(GD1)+1);
高點2:=REF(MAX(C,O),BARSLAST(GD2)+1);
高點:=IF(高點2>=高點1,高點2,高點1);
AA:=HHV(IF(C>O,C,MAX(C,O)),BARSLASTCOUNT(高點)+1)=HHV(IF(C>O,C,MAX(C,O)),BARSLASTCOUNT(BBI>REF(BBI,1)AND C>BBI));
壓力:DRAWLINE(BARSLAST(AA)=0,IF(C>O,C,MAX(C,O)),BARSNEXT(AA),REF(IF(C>O,C,MAX(C,O)),BARSLAST(AA)),1),DOTLINE,COLORYELLOW;
LD1:=EVERY(DIF<REF(DIF,1),BARSLASTCOUNT(DIF<DEA))AND DIF<DEA;
LD2:=EVERY(MACD<REF(MACD,1),BARSLASTCOUNT(DIF<DEA))AND DIF<DEA;
LD:=MIN(LD1,LD2);
低點1:=REF(MIN(C,O),BARSLAST(LD1)+1);
低點2:=REF(MIN(C,O),BARSLAST(LD2)+1);
低點:=IF(低點2<=低點1,低點1,低點2);
BB:=LLV(IF(C<O,C,MIN(C,O)),BARSLASTCOUNT(LD)+1)=LLV(IF(C<O,C,MIN(C,O)),BARSLASTCOUNT(DIF<REF(DIF,1) AND BBI<REF(BBI,1)}AND L<BBI));
支撐:DRAWLINE(BARSLAST(BB)=0,IF(C<O,C,MIN(C,O)),BARSNEXT(BB),REF(IF(C<O,C,MIN(C,O)),BARSLAST(BB)),1),DOTLINE,COLORGREEN;
PP1:=BARSLAST(AA)=1;
YLX:=REF(MAX(C,O),BARSLAST(PP1)+1);
突破:CROSS(C,YLX),NODRAW,COLORWHITE;
STICKLINE(突破,C,O,2,0),COLORWHITE;
DIF突破:=REF(DIF,BARSLAST(PP1)+1);
有效突破:=突破 AND DIF>DIF突破;
{STICKLINE(有效突破,C,O,2,0),COLORYELLOW};
PP2:=BARSLAST(BB)=1;
ZCX:=REF(MIN(C,O),BARSLAST(PP2)+1);
破位:CROSS(ZCX,C),NODRAW,COLORLIGREEN;
STICKLINE(破位,C,O,2,0),COLORLIGREEN;
PP7:=BARSLAST(破位)=1;
破位K線:=REF(O,BARSLAST(PP7)+1);
突破破位:CROSS(C,破位K線),NODRAW,COLORLIMAGENTA;
STICKLINE(突破破位 AND C>O AND MACD>REF(MACD,1),C,O,2,0),COLORLIMAGENTA;
六十天高點:=HHV(C,1)=HHV(C,60),NODRAW,COLORMAGENTA;
歷史新高:=HHV(C,1)=HHV(C,0),NODRAW,COLORRED;
六十天低點:=MIN(O,C)<=LLV(MIN(O,C),60)NODRAW,COLORCYAN;
歷史新低:=LLV(MIN(O,C),1)=LLV(MIN(O,C),0),NODRAW,COLORBLUE;
STICKLINE(六十天高點 AND C>O,C,O,2,0),COLORMAGENTA;
STICKLINE(六十天高點 AND C<O,O,(C+O)/2,2,0),COLORGREEN;
STICKLINE(六十天高點 AND C<O,C,(C+O)/2,2,0),COLORMAGENTA;
STICKLINE(六十天低點 AND C<O,C,O,2,0),COLORGREEN;
STICKLINE(六十天低點 AND C>O,C,(C+O)/2,2,0),COLORMAGENTA;
STICKLINE(六十天低點 AND C>O,O,(C+O)/2,2,0),COLORGREEN;
STICKLINE(歷史新高 AND C>O,C,O,2,0),COLORRED;
STICKLINE(歷史新高 AND C<O,O,(C+O)/2,2,0),COLORBLUE;
STICKLINE(歷史新高 AND C<O,C,(C+O)/2,2,0),COLORRED;
STICKLINE(歷史新低 AND C<O,C,O,2,0),COLORBLUE;
STICKLINE(歷史新低 AND C>O,C,(C+O)/2,2,0),COLORRED;
STICKLINE(歷史新低 AND C>O,O,(C+O)/2,2,0),COLORBLUE;
六十天壓力:DRAWLINE(BARSLAST(六十天高點)=0,C,BARSNEXT(六十天高點),REF(C,BARSLAST(六十天高點)),1),DOTLINE,COLORMAGENTA;
歷史壓力:DRAWLINE(BARSLAST(歷史新高)=0,C,BARSNEXT(歷史新高),REF(C,BARSLAST(歷史新高)),1),DOTLINE,COLORRED;
六十天支撐:DRAWLINE(BARSLAST(六十天低點)=0,MIN(C,O),BARSNEXT(六十天低點),REF(MIN(C,O),BARSLAST(六十天低點)),1),DOTLINE,COLORCYAN;
歷史支撐:DRAWLINE(BARSLAST(歷史新低)=0,MIN(C,O),BARSNEXT(歷史新低),REF(MIN(C,O),BARSLAST(歷史新低)),1),DOTLINE,COLORLIBLUE;
六十天前高:=六十天高點 AND REF(C,1)<C AND C>REFX(C,1);
PP3:=BARSLAST(六十天前高)=1;
六十天前高點:=REF(C,BARSLAST(PP3)+1);
突破60天壓力:CROSS(C,六十天前高點)NODRAW,COLORMAGENTA;
歷史前高:=歷史新高 AND REF(C,1)<C AND C>REFX(C,1);
PP4:=BARSLAST(歷史前高)=1;
歷史高點:=REF(C,BARSLAST(PP4)+1);
突破歷史壓力:CROSS(C,歷史高點)NODRAW,COLORRED;
PP5:=BARSLAST(六十天低點)=1;
破60天低點:CROSS(REF(C,BARSLAST(PP5)+1),C)NODRAW,COLORGREEN;
PP6:=BARSLAST(歷史新低)=1;
破歷史新低:CROSS(REF(C,BARSLAST(PP6)+1),C)NODRAW,COLORBLUE;
實體:=(C-O)/C=HHV((C-O)/C,15);
陽15:=C>O AND VOL>=HHV(VOL,15);
單陽:(C>REF(C,1)*1.035 OR 實體)AND C>O AND (陽15 OR VOL>REF(VOL,1)*1.9),NODRAW,COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT<100 AND 單陽,L*0.991,'陽'),COLOR00FFFF;
STICKLINE(單陽,O,C,2,0),COLOR00FFFF;
高不破價:=REF(C,BARSLAST(單陽));
低不破價:=REF(O,BARSLAST(單陽));
單陽不破:=CURRBARSCOUNT<100 AND BARSLAST(單陽)<11 AND LLV(C,BARSLAST(單陽))>=低不破價;
STICKLINE(單陽不破,低不破價,低不破價,4,0),COLORGREEN;
STICKLINE(單陽不破,高不破價,高不破價,4,0),COLORWHITE;
DRAWTEXT(BARSLAST(單陽)=01 AND 單陽不破,低不破價*0.99,'1'),COLORLIGRAY;
DRAWTEXT(BARSLAST(單陽)=02 AND 單陽不破,低不破價*0.99,'2'),COLORLIGRAY;
DRAWTEXT(BARSLAST(單陽)=03 AND 單陽不破,低不破價*0.99,'3'),COLORLIGRAY;
DRAWTEXT(BARSLAST(單陽)=04 AND 單陽不破,低不破價*0.99,'4'),COLORLIGRAY;
DRAWTEXT(BARSLAST(單陽)=05 AND 單陽不破,低不破價*0.99,'5'),COLORLIGRAY;
DRAWTEXT(BARSLAST(單陽)=06 AND 單陽不破,低不破價*0.99,'6'),COLORLIGRAY;
DRAWTEXT(BARSLAST(單陽)=07 AND 單陽不破,低不破價*0.99,'7'),COLORLIGRAY;
DRAWTEXT(BARSLAST(單陽)=08 AND 單陽不破,低不破價*0.99,'8'),COLORLIGRAY;
DRAWTEXT(BARSLAST(單陽)=09 AND 單陽不破,低不破價*0.99,'9'),COLORLIGRAY;
DRAWTEXT(BARSLAST(單陽)=10 AND 單陽不破,低不破價*0.99,'10'),COLORLIGRAY;
PP8:=BARSLAST(單陽不破)=0;
ZCX1:=REF(低不破價,BARSLAST(PP8)+1);
破單陽:=CROSS(ZCX1,C),NODRAW,COLORLIGREEN;
STICKLINE(破單陽,C,O,2,0),COLORLIGREEN;

通達信有效突破主圖指標公式

 

相關文章

澳洲幸运5号码统计 世界杯网上能投注吗 股票分析软件推荐 500元 倍投方案 稳赚快三 捕鱼达人3d有遥控器吗 股票融资方法有哪些 11选5的计划软件手机版 捕鱼达人破解版内购单机版 承包40人食堂赚钱吗 极速pk拾 正宗台湾公司台老虎机 赚钱不养台独 电子鸡怎么玩 重庆时时开奖官网 max泰拳比赛官网 ag电子游戏控制 pk10技巧5码公式