澳洲幸运5号码统计|澳洲幸运5是哪个国家的
在線檢測未來函數

通達信汽槍獵殺及選股指標公式

來源:Internet,編輯:股旁網,2019-04-03

汽槍:=SMA(SMA((C-LLV(L,80))/(HHV(H,80)-LLV(L,80))*100,10,1),10,1),LINETHICK2;
收兵:=SMA(汽槍,10,1),LINETHICK2,COLOR808000;
W1:=SMA((HHV(H,80)-C)/(HHV(H,80)-LLV(L,80))*100,10,1);
瞄準:SMA(W1,10,1),CIRCLEDOT,COLOR00DD00,LINETHICK1;
天空:STICKLINE(C,85,85,5,1);
大地:STICKLINE(C,9,9,5,1);
W2:=(CROSS(收兵,汽槍) AND 收兵>20);
W3:=(CROSS(汽槍,收兵) AND 收兵<20);
DRAWTEXT(CROSS(收兵,汽槍) AND 收兵>20,58,'殺'),COLORFF00FF;
DRAWTEXT(CROSS(收兵,汽槍) AND 收兵<50 AND 收兵>20,汽槍,' 留意!'),COLORFF00FF;
IF(W2,60,85),COLOR00DD00;
IF(W3,40,9),COLORFF00FF;
DRAWTEXT(CROSS(汽槍,收兵) AND 收兵<20,48,'獵'),COLORFF00FF;
DRAWTEXT(CROSS(瞄準,80),82,'●'),COLORRED;
DRAWTEXT(CROSS(瞄準,80),76,'瞄準'),COLORRED;
DRAWTEXT(CROSS(瞄準,85),84,'●'),COLORWHITE;
DRAWTEXT(CROSS(瞄準,85),78,'獵物出現'),COLORWHITE;
VAR1:=4*SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1),3,1);
VAR2:=8;
底部出擊: IF(CROSS(VAR1,VAR2),50,9),COLORRED;
A1:=CROSS(汽槍,85) AND 汽槍>=85;
再來一槍:IF(A1,60,85),COLORYELLOW;
獵殺:瞄準<REF(瞄準,1) AND REF(瞄準,2)<REF(瞄準,1) AND 瞄準>=90;
DRAWTEXT(獵殺=1,95,'★'),COLORYELLOW;
DRAWTEXT(獵殺=1,93,'獵殺'),COLORRED;
成功:瞄準<REF(瞄準,1) AND REF(瞄準,2)>REF(瞄準,1) AND CROSS(85,瞄準);
DRAWTEXT(成功=1,85,'◆●'),COLORYELLOW;
DRAWTEXT(成功=1,83,'成功'),COLOR17CCC8;
VA1:=MA(L,1);
VA2:=MA(H,2);
VAR3:=MA(C,2);
VAR4:=(VAR3-LLV(VA1,9))/(HHV(VA2,9)-LLV(VA1,9))*100;
VAR5:=SMA(VAR4,3,1);
【陽】:SMA(VAR5,3,1),LINETHICK2,COLOR0000FF;
K2:=BACKSET(【陽】<REF(【陽】,1),2);
IF(K2,【陽】,DRAWNULL),COLOR00A600,LINETHICK2;
IF(【陽】>REF(【陽】,1),【陽】,DRAWNULL),COLOR740AF5,LINETHICK8,POINTDOT;
Y1:=SMA(【陽】,3,1);
VAR6:=(HHV(VA2,9)-VAR3)/(HHV(VA2,9)-LLV(VA1,9))*100;
【陰】:SMA(VAR6,3,1),LINETHICK2,COLORWHITE;
Y2:=SMA(【陰】,3,1);
VAR7:=REF(VAR3,1);
VAR8:=SMA(MAX(VAR3-VAR7,0),13,1)/SMA(ABS(VAR3-VAR7),13,1)*100;
VARB:=MA(INDEXC,3)*100/MA(INDEXC,10)-100;
VARC:=MA(C,3)*100/MA(C,10)-100;
VARD:=C*100/MA(C,10)-100;
VARE:=IF(VARB>10,10,VARB);
VARF:=IF(VARE<-10,-10,VARE);
VAR10:=IF(VARC>10,10,VARC);
VAR11:=IF(VAR10<-10,-10,VAR10);
VAR12:=REF(VARB,1);
VAR13:=100*(VAR3-REF(VAR3,1))/REF(VAR3,1);
VAR14:=INDEXC;
VAR15:=REF(VAR14,1);
VAR16:=100*(VAR14-VAR15)/VAR14;
VAR17:=MA(VAR13,3);
VAR18:=MA(VAR16,3);
VAR19:=(3*C+VAR1+O+H)/6;
VAR1A:=(20*VAR19+19*REF(VAR19,1)+18*REF(VAR19,2)+17*REF(VAR19,3)+16*REF(VAR19,4)+15*REF(VAR19,5)+14*REF(VAR19,6)+13*REF(VAR19,7)+12*REF(VAR19,8)+11*REF(VAR19,9)+10*REF(VAR19,10)+9*REF(VAR19,11)+8*REF(VAR19,12)+7*REF(VAR19,13)+6*REF(VAR19,14)+5*REF(VAR19,15)+4*REF(VAR19,16)+3*REF(VAR19,17)+2*REF(VAR19,18)+REF(VAR19,20))/210;
VAR1B:=MA(VAR1A,12);
VAR1C:=EMA(VAR1A,5);
VAR1D:=ABS(VAR1A-VAR1B);
VAR1E:=REF(VAR3,1)*0.015;
VAR1F:=REF(INDEXC,1);
D1:=EMA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5);
D2:=REF(D1,1);
STICKLINE(D1>=REF(D1,1),D1,D2,2.5,0),COLOR00AAFF;
STICKLINE(D1>=REF(D1,1),D1,D2,1.5,0),COLOR99AAFF;
STICKLINE(D1>=REF(D1,1),D1,D2,1,0),COLOR99DDFF;
【強弱】:SMA(MAX(VAR3-VAR7,0),5,1)/SMA(ABS(VAR3-VAR7),5,1)*100,LINETHICK2,COLORYELLOW;
DRAWTEXT(ISLASTBAR=1 AND CROSS(【強弱】,【陽】),【陽】,'短期吃貨!'),COLORFFFFCC;
DRAWTEXT( CROSS(【強弱】,【陽】),【強弱】,'←◆'),COLORRED;
DRAWTEXT( CROSS(【強弱】,【陽】),【強弱】,'←吃貨'),COLORRED;
DRAWTEXT(ISLASTBAR=1 AND CROSS(【陽】,【強弱】),【陽】,'短期出貨!'),COLOR00FF00;
DRAWTEXT( CROSS(【強弱】,【陰】),【強弱】,'●▼'),COLORCYAN;
DRAWTEXT( CROSS(【強弱】,【陰】),【強弱】,'←出貨!'),COLORCYAN;
DRAWTEXT(ISLASTBAR=1 AND VAR17>VAR18,60,'個股強于大盤!'),COLORFF66FF;
DRAWTEXT(ISLASTBAR=1 AND VAR12>VARF,50,'大盤處在下降通道'),COLORCCFF99;
DRAWTEXT(ISLASTBAR=1 AND VAR18>=VAR17,60,'個股弱于大盤!'),COLORFFFF00;
DRAWTEXT(ISLASTBAR=1 AND VAR1A>VAR1B AND VAR1D>VAR1E AND NOT(CROSS(75,VAR8)),40,' 持股待漲!'),COLOR6699FF;
DRAWTEXT(ISLASTBAR=1 AND VAR1A<VAR1E AND NOT(CROSS(【強弱】,20)),40,'下調減持!'),COLORFF9900;
DRAWTEXT(ISLASTBAR=1 AND VAR1D<=VAR1E,40,'盤整階段!'),COLORFF9900;
DRAWTEXT(ISLASTBAR=1 AND (INDEXC-VAR1F)/VAR1F>0.035,40,'出現井噴行情!');

{
選股公式:

獵槍:=SMA(SMA((C-LLV(L,80))/(HHV(H,80)-LLV(L,80))*100,10,1),10,1);
收兵:=SMA(獵槍,10,1);
W1:=SMA((HHV(H,80)-C)/(HHV(H,80)-LLV(L,80))*100,10,1);
瞄準:=SMA(W1,10,1);
W3:=(CROSS(獵槍,收兵) AND 收兵<20);
VAR1:=4*SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1),3,1);
VAR2:=8;
底部出擊:=CROSS(VAR1,VAR2);
開槍:=瞄準<REF(瞄準,1) AND REF(瞄準,2)<REF(瞄準,1) AND 瞄準>=90;
成功:=瞄準<REF(瞄準,1) AND REF(瞄準,2)>REF(瞄準,1) AND CROSS(85,瞄準);
D1:=EMA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5);
VA1:=MA(L,1);
VA2:=MA(H,2);
VAR3:=MA(C,2);
VAR4:=(VAR3-LLV(VA1,9))/(HHV(VA2,9)-LLV(VA1,9))*100;
VAR5:=SMA(VAR4,3,1);
【陽】:=SMA(VAR5,3,1);
VAR7:=REF(VAR3,1);
【強弱】:=SMA(MAX(VAR3-VAR7,0),5,1)/SMA(ABS(VAR3-VAR7),5,1)*100;
XG:REF(底部出擊=1,6) OR D1>=REF(D1,1) AND CROSS(【強弱】,【陽】);
}

通達信汽槍獵殺及選股指標公式

 

相關文章

澳洲幸运5号码统计