澳洲幸运5号码统计|澳洲幸运5是哪个国家的
在線檢測未來函數

同花順機構利器指標公式

來源:Internet,編輯:股旁網,2017-05-16

////主力動向+主力趨勢雷達///
r0:=((IF(ISNULL(ZDMR[-1]),0,ZDMR)+IF(ISNULL(BDMR[-1]),0,BDMR))-(IF(ISNULL(ZDMC[-1]),0,ZDMC)+IF(ISNULL(BDMC[-1]),0,BDMC)))/SHGZG*100;
MA5:=MA(r0,5);
//超買:3.2,coloryellow;//讓位趨勢決策線
//超賣:0.5,coloryellow;//讓位花神線
最小值:=LLV(LOW,10);
最大值:=HHV(HIGH,25);
波動線:=EMA((CLOSE-最小值)/(最大值-最小值)*4,4);
均線:EMA(波動線,3);
主力攻擊:=r0-(ABS(REF(r0,1))+ABS(REF(r0,2))+ABS(REF(r0,3))+ABS(REF(r0,4))+ABS(REF(r0,5))/2)>0 AND 平均線>=REF(平均線,1) AND REF(平均線,1)<REF(平均線,2);
主力撤退:=-((r0+(ABS(REF(r0,1))+ABS(REF(r0,2))+ABS(REF(r0,3))+ABS(REF(r0,4))+ABS(REF(r0,5))/2)<0) AND 平均線<=REF(平均線,1) AND REF(平均線,1)>REF(平均線,2));
DRAWTEXT(主力攻擊>0,1.5,"主進"),colorred;
DRAWTEXT(主力撤退<0,2.8,"主退"),colorgreen;
信息:=平均線>=REF(平均線,1);
走強:=CLOSE>MA(CLOSE,20)AND CLOSE>MA(CLOSE,5);
走弱:=CLOSE<MA(CLOSE,10)AND CLOSE<MA(CLOSE,5);
量:=VOL>MA(VOL,5);
STICKLINE(平均線>=REF(平均線,1),波動線,REF(波動線,1),5,0),colorred;
STICKLINE(平均線<REF(平均線,1),波動線 ,REF(波動線,1),5,0),colorgreen;
d:=信息=1 AND REF(信息,1)=0 AND (REF(信息,2)+REF(信息,3)=0) AND 平均線<0.5;
s:=信息=1 AND REF(信息,1)=0 AND (REF(信息,2)+REF(信息,3)=0) AND 走強=1 AND REF(走強,1)=0 AND 量=1;
dd:=平均線>2 AND (信息=0 AND REF(信息,1)=1) AND (REF(信息,2)+REF(信息,3)=2);
tz:=(信息=0 AND REF(信息,1)=1) AND (REF(信息,2)+REF(信息,3)=2) AND MA5<0 AND 走弱=1 AND 平均線>1;
DRAWTEXT(d=1,1.75,'極底'),colorred;
DRAWTEXT(s=1,平均線,'升');
DRAWTEXT(dd=1,平均線,'頂');
DRAWTEXT(tz=1,平均線,'下');
PARTLINE(平均線,平均線>=REF(平均線,1),colorred,平均線<REF(平均線,1),colorgreen);
////機構建倉////
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
Zcjl:=(RSI5 - WR10);
最佳買入:=(AV + Zcjl);
最佳買入選股:=IF(CROSS(最佳買入,0),1,0);
VAR5:=SMA(最佳買入選股,3,1);
VAR6:=SMA(VAR5,3,1);
VAR7:=SMA(VAR6,3,1);
建倉買點:=IF(CROSS(VAR6,VAR7) AND (VAR6<40),5,0);
DRAWTEXT(建倉買點,0.75,'建倉'),colorred;
////機構利器////
VAR8:=REF(CLOSE,2);
會員:=SMA(MAX(CLOSE-VAR8,0),7,1)/SMA(ABS(CLOSE-VAR8),7,1)*100;
逃亡:=IF(會員< REF(會員,1) AND 會員>79,會員,0);
DRAWTEXT(逃亡,3.1,'逃'),coloryellow;
DRAWTEXT(88>0 AND REF(O,1)/REF(C,1)>1.04 AND REF(L,1)<=688 AND O>REF(C,1)AND C<REF(O,1)AND C/O>=1.01,1,'見底'),colorlired;
DRAWTEXT(C-O>=0 AND O/L>1.05 AND L<=LLV(L,20),1,'絕底'),colorred;
///主力吸貨////
VAR11:=REF(LOW,1);
VAR12:=SMA(ABS(LOW-VAR11),3,1)/SMA(MAX(LOW-VAR11,0),3,1)*100;
VAR13:=EMA(IF(CLOSE*1.2,VAR12*10,VAR12/10),3);
VAR14:=LLV(LOW,38);
VAR15:=HHV(VAR13,38);
VAR16:=IF(LLV(LOW,90),1,0);
VAR17:=EMA(IF(LOW<=VAR14,(VAR13+VAR15*2)/2,0),3)/618*VAR16;
Cdxs:=HHV(VAR17,0)/2.6;
STICKLINE(VAR17,0.53,VAR17/Cdxs+0.53,1,0),colorwhite;
////馬上成功////
Hua:=(CLOSE - LLV(LOW,14)) / (HHV(HIGH,14) - LLV(LOW,14)) * 1.2 * CLOSE;
Nv1:=EMA(Hua,4);
Nv2:=EMA(Hua,8);
DRAWICON(CROSS(Nv1,Nv2) AND CLOSE/OPEN>1.05,0.5,1);
DRAWICON(CROSS(Nv2,Nv1) AND COUNT(CROSS(Nv1,Nv2) AND CLOSE/OPEN>1.05 ,20) ,3.2,2);
////必漲之星////
Hua2:=SMA(MAX(CLOSE-REF(CLOSE,1),0),16,2)/SMA(ABS(CLOSE/REF(CLOSE,1)),16,2)*100;
Xian=SMA(Hua2,3,1);
Nv3:=SMA(Xian,3,1);
XiNv=3*Xian-2*Nv3;
買入條件:=CROSS(XiNv,Nv3);
賣出條件:=CROSS(Nv3,XiNv);
DRAWICON( 賣出條件,3.3,2),coloryellow;
DRAWICON(買入條件,0.4,222),colorwhite;//必漲之星
Hxn:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);//花仙女漲停
DRAWTEXT(Hxn>90 AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1) AND COUNT(Hxn>90,30)=1,平均線-0.25, '見漲'),,colorlired;
Hxjz:=MA((2*CLOSE+HIGH+LOW)/4,5);//花仙女絕招
Bztd:=Hxjz*89/100;
DRAWTEXT(CROSS(LOW,Bztd),1.25,'必漲'),colorred;
////花神////
花:=EMA(SLOPE(1,1)+C,3),colorred;
女:=EMA(SLOPE(1,1)+C,7),colorblue;
STICKLINE(花>女 ,0.5,0.53,12,0) ,colorred;//花神線,紅色開始為買
STICKLINE(花<=女 ,0.5,0.53,12,0),colorgreen;//花神線,綠色開始為賣
///資金抄底///
rj:=((ZDMR[-1]+BDMR[-1])-(ZDMC[-1]+BDMC[-1]))/SHGZG*100;//大單凈量
RSI$1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
RSI$2:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
RSI$3:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
相對強弱:=0.5*RSI$1+0.31*RSI$2+0.19*RSI$3;
wave$1:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),3,1);
wave$2:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),5,1);
wave$3:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),8,1);
短線波段:=0.5*wave$1+0.31*wave$2+0.19*wave$3;
風險系數:=0.5*相對強弱+0.5*短線波段,coloryellow;
CD1:=IF(風險系數<20 AND CLOSE>OPEN AND rj>0,1,0);//波段小于20,股價翻紅;
CD2:=IF(風險系數<20 AND LOW>=REF(LOW,1) AND CLOSE>LOW AND rj>0,1,0);//波段小于20,股價未翻紅,但未創新低;
CD3:=IF(REF(風險系數,1)<20 AND 風險系數>REF(風險系數,1),1,0);//前一日波段小于20,今日轉向;
SIGNALBUY=(CD1=1 OR CD2=1 OR CD3=1);
cd=(SIGNALBUY AND COUNT(SIGNALBUY,3)=1);
DRAWTEXT(cd,0.5,'抄底'),COLOR0099FF;
///金叉共振///
DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100;
DEA:=EMA(DIF,9);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,9,3);
D:=SMA(K,9,3);
GZ:=CROSS(DIF,DEA) AND CROSS(K,D);
DRAWTEXT(GZ,2,'金叉'),COLOR0099FF;
////趨勢決策////
大單凈差BBD:=BIGBUYCOUNT1+WAITBUYCOUNT1-BIGSELLCOUNT1-WAITSELLCOUNT1;
DIFF:=EMA(大單凈差BBD,2) - EMA(大單凈差BBD,4),coloryellow;
DIFF2:=EMA(大單凈差BBD,6) - EMA(大單凈差BBD,12),coloryellow;
m34:=MA(C,34);
m5:=MA(C,5);
r5:=COUNT(大單凈差BBD>0,5);
r6:=COUNT(大單凈差BBD>0,6);
A1:=IF(C<REF(C,2)*1.0200,1,0);
a2:=IF(C<REF(C,2)*1.0050,1,0);
a3:=IF(C<REF(C,2)*0.0985,1,0);
a4:=IF(C<REF(C,2)*0.0970,1,0);
a5:=IF(DIFF>0,2,0);
a6:=IF(DIFF2>0,2,0);
a7:=IF(C>m34,2,0);
a8:=IF(C>m5,2,0);
a9:=IF(r5>3,2,0);
a10:=IF(r6>3,1,0);
az:=A1+a2+a3+a4+a5+a6+a7+a8+a9+a10;
IF(C<m5)
green:=C<m5;
ELSE IF(az>2.5)
red:=az>2.5;
ELSE green:=az<2.5;
ENTERLONG:=(REF(green,1)=1 AND red=1 ) AND COUNT(REF(green,1)=1 AND red=1,BARSLAST(REF(red,1)=1 AND green=1))=1;
EXITLONG:=REF(red,1)=1 AND green=1 AND COUNT(REF(red,1)=1 AND green=1,BARSLAST(REF(green,1)=1 AND red=1))=1;
IF(C<m5){STICKLINE(C<m5,3.2,3.22,12,0),colorgreen;}
ELSE IF(az>2.5){STICKLINE(az>2.5,3.2,3.22,12,0),colorred;}
ELSE IF(az<=2.5){STICKLINE(az<=2.5,3.2,3.22,12,0),colorgreen;}
DRAWTEXT_FIX(1,0.01,0.2,0,'趨勢決策線'),colormagenta;
DRAWTEXT_FIX(1,0.01,1.1,0,'花神線'),colormagenta;

同花順機構利器指標公式

 

相關文章

澳洲幸运5号码统计