澳洲幸运5号码统计|澳洲幸运5是哪个国家的
在線檢測未來函數

將立竿見影通達信副圖改為大智慧格式

來源:Internet,編輯:股旁網,2012-04-01

編寫要求:

股旁網解答:

 網友求助:

請老師將立竿見影通達信副圖及選股公式改為大智慧格式,謝謝老師!
{立竿見影通達信副圖}
VAR1:(CLOSE-MA(CLOSE,12))/MA(CLOSE,1)*100,COLORGREEN,LINETHICK2;
VAR2:IF((VAR1 > 0),VAR1,0),CIRCLEDOT;
VAR4:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
VAR5:=(EMA(VAR4,3)-50)*2;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13),COLORGREEN,LINETHICK2;
VAR10:EMA(0.382*REF(VAR9,2)+0.618*VAR9,6),COLORRED;
DRAWICON(CROSS(VAR9,VAR10-2),VAR10,5);
STICKLINE(VAR2>=0,0,VAR2,8,0),COLORRED;
DRAWICON(CROSS(VAR5,-80),VAR1,25);
立竿見影:IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,23,0),LINETHICK2;
DRAWICON(立竿見影=23,23,1);
E:=CROSS(83,RSI);
STICKLINE( E,70,80,4,0),COLOR00FF00;
DRAWTEXT(E,66,' 逃頂');
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳買入:=(AV + NEWVOL);
最佳買入選股:IF(CROSS(最佳買入,0),61,0),STICK,COLORRED,LINETHICK4;
DRAWTEXT(CROSS(最佳買入,0),62,'最佳買入'),COLOR00FFFF;
STICKLINE(最佳買入選股,0,0.3,7.5,0),COLOR102099;
STICKLINE(最佳買入選股,0,0.3,6,0),COLOR1020AA;
STICKLINE(最佳買入選股,0,0.3,5.5,0),COLOR1020BB;
STICKLINE(最佳買入選股,0,0.3,4,0),COLOR1020CC;
STICKLINE(最佳買入選股,0,0.1,3.5,0),COLOR1020DD;
STICKLINE(最佳買入選股,0,0.1,2,0),COLOR1020EE;
天:80,POINTDOT,COLORBLUE,LINETHICK4;
海:20,POINTDOT,COLORRED,LINETHICK4;
AA:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
BB:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
CC:=EMA(AA,2);
DD:=EMA(BB,5);
TJ0:=CROSS(CC,DD);
上:=EMA(C,3);
中:=EMA(C,5);
下:=EMA(中,5);
TJ1:=CROSS(上,中);
TJ2:=上>REF(上,1);
X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,5)-REF(EMA(X1,5),1))*3.1416*10;
EMA3:=EMA(C,3);
TJ3:=BB5>1 AND EMA(X1,5)>REF(EMA(X1,3),1);
STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,50,4,0)COLOR009999;
STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,50,3,0)COLOR00BBBB;
STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,50,1.5,0)COLOR00DDDD;
STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,50,0.6,0)COLOR00FFFF;
DRAWTEXT(TJ1 AND TJ2 AND TJ0 AND TJ3,48,'齋主全倉'),COLORRED;
齋主全倉:IF(CROSS('齋主全倉',0),0.9,0),STICK,COLORRED;
VARH2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VARH3:=SMA(SMA(VARH2,3,1),3,1)/28.57;
VARH4:=EMA(VARH3,5);
操盤:=3*VARH3-2*VARH4;
AH1:=CROSS(操盤,VARH3) AND VARH3<2.1 AND C>O;
STICKLINE(AH1,50,0,4,0),COLOR770077;
STICKLINE(AH1,50,0,3,0),COLOR990099;
STICKLINE(AH1,50,0,2,0),COLORBB00BB;
STICKLINE(AH1,50,0,1,0),COLORDD00DD;
STICKLINE(AH1,56,0,0.3,0),COLOR00FFFF;
DRAWTEXT(AH1,56,'財神'),COLORRED;

{立竿見影通達信選股}
AA:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
BB:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
CC:=EMA(AA,2);
DD:=EMA(BB,5);
TJ0:=CROSS(CC,DD);
上:=EMA(C,3);
中:=EMA(C,5);
下:=EMA(中,5);
TJ1:=CROSS(上,中);
TJ2:=上>REF(上,1);
X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,5)-REF(EMA(X1,5),1))*3.1416*10;
TJ3:=BB5>1 AND EMA(X1,5)>REF(EMA(X1,3),1);
齋主全倉:TJ1 AND TJ2 AND TJ0 AND TJ3;
逃頂:CROSS(83,RSI);
VAR4:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
VAR5:=(EMA(VAR4,3)-50)*2;
紅鉆:CROSS(VAR5,-80);
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VAR10:=EMA(0.382*REF(VAR9,2)+0.618*VAR9,6);
笑臉:CROSS(VAR9,VAR10-2);
VARH2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VARH3:=SMA(SMA(VARH2,3,1),3,1)/28.57;
VARH4:=EMA(VARH3,5);
操盤:=3*VARH3-2*VARH4;
財神:CROSS(操盤,VARH3) AND VARH3<2.1 AND C>O;
VAR3:=(CLOSE-LLV(CLOSE,124))/(HHV(CLOSE,124)-LLV(CLOSE,124))*100;
VARA:=(VAR5 OR VAR9) AND VAR4 AND VAR8;
VARB:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
VARC:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
VARD:=SMA(VARC,3,2);
VARE:=SMA(VARD,3,2);
VARF:=SMA(VARE,5,1);
底部來臨: IF(FILTER(VARA,10)=1,1,0),COLOR00FF00;
止跌: IF(FILTER(VAR10,3)=1,1,0),COLORFFCC66;
牛勢股票: REF(VARB,1)>=16 AND REF(VARB,1)/VARB>=1.23 AND CROSS(VARE,VARF),COLORRED;
STICKLINE(牛勢股票>0,0.9,1.05,10,0),COLORRED;
DRAWTEXT(底部來臨,0.25,'底部買點'),COLOR00FF00;
DRAWTEXT(牛勢股票,0.85,'牛勢再現'),COLORWHITE;
DRAWTEXT(止跌,0.6,'止跌轉牛勢'),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳買入:=(AV + NEWVOL);
最佳買入選股:CROSS(最佳買入,0);

 
解答如下:
VAR1:(CLOSE-MA(CLOSE,12))/MA(CLOSE,1)*100,COLORGREEN,LINETHICK2;
VAR2:IF((VAR1 > 0),VAR1,0),CIRCLEDOT;
VAR4:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
VAR5:=(EMA(VAR4,3)-50)*2;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13),COLORGREEN,LINETHICK2;
VAR10:EMA(0.382*REF(VAR9,2)+0.618*VAR9,6),COLORRED;
DRAWICON(CROSS(VAR9,VAR10-2),VAR10,5);
STICKLINE(VAR2>=0,0,VAR2,8,0),COLORRED;
DRAWICON(CROSS(VAR5,-80),VAR1,25);
立竿見影:IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,23,0),LINETHICK2;
DRAWICON(立竿見影=23,23,1);
LC:=REF(CLOSE,1);
RSI:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
E:=CROSS(83,RSI);
STICKLINE( E,70,80,4,0),COLOR00FF00;
DRAWTEXT(E,66,' 逃頂');
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳買入:=(AV + NEWVOL);
最佳買入選股:IF(CROSS(最佳買入,0),61,0),STICK,COLORRED,LINETHICK4;
DRAWTEXT(CROSS(最佳買入,0),62,'最佳買入'),COLOR00FFFF;
STICKLINE(最佳買入選股,0,0.3,7.5,0),COLOR102099;
STICKLINE(最佳買入選股,0,0.3,6,0),COLOR1020AA;
STICKLINE(最佳買入選股,0,0.3,5.5,0),COLOR1020BB;
STICKLINE(最佳買入選股,0,0.3,4,0),COLOR1020CC;
STICKLINE(最佳買入選股,0,0.1,3.5,0),COLOR1020DD;
STICKLINE(最佳買入選股,0,0.1,2,0),COLOR1020EE;
天:80,POINTDOT,COLORBLUE,LINETHICK4;
海:20,POINTDOT,COLORRED,LINETHICK4;
AA:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
BB:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
CC:=EMA(AA,2);
DD:=EMA(BB,5);
TJ0:=CROSS(CC,DD);
上:=EMA(C,3);
中:=EMA(C,5);
下:=EMA(中,5);
TJ1:=CROSS(上,中);
TJ2:=上>REF(上,1);
X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,5)-REF(EMA(X1,5),1))*3.1416*10;
EMA3:=EMA(C,3);
TJ3:=BB5>1 AND EMA(X1,5)>REF(EMA(X1,3),1);
STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,50,4,0),COLOR009999;
STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,50,3,0),COLOR00BBBB;
STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,50,1.5,0),COLOR00DDDD;
STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,50,0.6,0),COLOR00FFFF;
DRAWTEXT(TJ1 AND TJ2 AND TJ0 AND TJ3,48,'齋主全倉'),COLORRED;
VARH2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VARH3:=SMA(SMA(VARH2,3,1),3,1)/28.57;
VARH4:=EMA(VARH3,5);
操盤:=3*VARH3-2*VARH4;
AH1:=CROSS(操盤,VARH3) AND VARH3<2.1 AND C>O;
STICKLINE(AH1,50,0,4,0),COLOR770077;
STICKLINE(AH1,50,0,3,0),COLOR990099;
STICKLINE(AH1,50,0,2,0),COLORBB00BB;
STICKLINE(AH1,50,0,1,0),COLORDD00DD;
STICKLINE(AH1,56,0,0.3,0),COLOR00FFFF;
DRAWTEXT(AH1,56,'財神'),COLORRED;

{立竿見影通達信選股}
AA:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
BB:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
CC:=EMA(AA,2);
DD:=EMA(BB,5);
TJ0:=CROSS(CC,DD);
上:=EMA(C,3);
中:=EMA(C,5);
下:=EMA(中,5);
TJ1:=CROSS(上,中);
TJ2:=上>REF(上,1);
X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,5)-REF(EMA(X1,5),1))*3.1416*10;
TJ3:=BB5>1 AND EMA(X1,5)>REF(EMA(X1,3),1);
齋主全倉:TJ1 AND TJ2 AND TJ0 AND TJ3;
逃頂:CROSS(83,RSI);
VAR4:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
VAR5:=(EMA(VAR4,3)-50)*2;
紅鉆:CROSS(VAR5,-80);
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VAR10:=EMA(0.382*REF(VAR9,2)+0.618*VAR9,6);
笑臉:CROSS(VAR9,VAR10-2);
VARH2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VARH3:=SMA(SMA(VARH2,3,1),3,1)/28.57;
VARH4:=EMA(VARH3,5);
操盤:=3*VARH3-2*VARH4;
財神:CROSS(操盤,VARH3) AND VARH3<2.1 AND C>O;
VAR3:=(CLOSE-LLV(CLOSE,124))/(HHV(CLOSE,124)-LLV(CLOSE,124))*100;
VARA:=(VAR5 OR VAR9) AND VAR4 AND VAR8;
VARB:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*(-100);
VARC:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
VARD:=SMA(VARC,3,2);
VARE:=SMA(VARD,3,2);
VARF:=SMA(VARE,5,1);
底部來臨: IF(FILTER(VARA,10)=1,1,0),COLOR00FF00;
止跌: IF(FILTER(VAR10,3)=1,1,0),COLORFFCC66;
牛勢股票: REF(VARB,1)>=16 AND REF(VARB,1)/VARB>=1.23 AND CROSS(VARE,VARF),COLORRED;
STICKLINE(牛勢股票>0,0.9,1.05,10,0),COLORRED;
DRAWTEXT(底部來臨,0.25,'底部買點'),COLOR00FF00;
DRAWTEXT(牛勢股票,0.85,'牛勢再現'),COLORWHITE;
DRAWTEXT(止跌,0.6,'止跌轉牛勢'),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳買入:=(AV + NEWVOL);
最佳買入選股:CROSS(最佳買入,0);

 

相關文章

股票公式月點擊榜

股票公式年點擊榜

股票公式總點擊榜

澳洲幸运5号码统计